Node.JS MariaSQL npn module Install for Windows

Windows 에서 npm 을 이용해 MariaSQL Module 을 설치하기 전 먼저 설치해야 할 것 들이 있습니다.

MariaSQL module 설치 시 사전에 필요한 설치하지 않을 경우

Python 미설치 시

gyp ERR! stack Error: Can’t find Python excutable “python”, you can set the PYTHON env variable.

VS 2015 미설치 시 zlib.vcxproj 프로젝트의 빌드를 시도하다가

 gyp ERR! build error

가 나타납니다.

 

(1) Python 2.x 버전

파이썬 2.x(현재 최신버전) 의 설치가 필요합니다.

3.x 버전은 안됩니다.

다운로드 링크:  https://www.python.org/downloads/

 

(2) Visual Studio 2015

라이브러리 빌드를 위해 VC++ 컴파일러를 일부 사용합니다. 그래서 Visual Studio 2015 가 필요합니다.  (커뮤니티 버전 이상이면 됩니다.)

테스트 결과 안타깝게도 아직 Visual Studio 2017 은 지원하지 않습니다.

설치 시 ‘프로그래밍 언어’ 에서 ‘Visual C++’ 을 선택해 설치하셔야 합니다.

이 두가지 설치가 완료되면 MariaSQL Module 을 설치하실 수 있습니다. (이 문서가 만들어진 때는 0.2.6 버전 입니다.)

다운로드 링크: https://www.visualstudio.com/ko/vs/older-downloads/  (로그인이 필요합니다.)

답글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다.