Ruby Gem Update 시 HTTP Response 302 오류 발생시 대처방법

redmine 설치 중…
Ruby 를 처음 설치한 후 업데이트 시 오류가 발생했었습니다.

>> gem update –system

명령을 실행했을 때

Updating RubyGems…
ERROR:  While executing gem … <Gem::RemoteSourceException>
HTTP Response 302

와 같은 오류 메시지가 나타났고, 구글링을 한 뒤 아래와 같이 해결하였습니다.

>> gem update –system –source http://production.s3.rubygems.org

그리고

>> gem update –system

이렇게 명령을 내려 최신 버전의 gem 으로 업데이트 되었습니다.

추가로 rails 가 설치가 안 될 경우…

>>gem install rails -v=2.3.5

로 해결하였습니다.

답글 남기기

이메일은 공개되지 않습니다. 필수 입력창은 * 로 표시되어 있습니다.